pub_client 3.0.3

Dart native js
Flutter Android iOS web

A library for interacting with the REST API for Pub (pub.dartlang.org/api).

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  pub_client: ^3.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pub_client/pub_client.dart';
1
likes
80
pub points
32%
popularity

A library for interacting with the REST API for Pub (pub.dartlang.org/api).

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jim.j.simon@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

http, json_annotation

More

Packages that depend on pub_client