provider_view_controller 0.0.4

provider_view_controller #

This package is merged with the fluttered package. Further development will be done on the fluttered package. Do not depend on this package. Use the fluttered package instead.

[0.0.1]

  • Initial release.

[0.0.2]

  • StatelessMutablePVC widget added

[0.0.3]

  • StatelessImmutablePVC, StatefulMutablePVC and StatefulImmutablePVC added. Check out the documentaton for more details.

[0.0.4]

  • This package is merged with fluttered. Further development will be done on the fluttered package. Do not depend on this package. Use the fluttered package instead.

example/README.md

provider_view_controller_example #

Demonstrates how to use the provider_view_controller package.

Quick test #

flutter run

Specific app entry point

flutter run -t lib/main.dart

Getting Started #

For help getting started with Flutter, view the online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  provider_view_controller: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:provider_view_controller/provider_view_controller.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
provider ^3.0.0 3.0.0+1
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin