fluttered 0.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 56

fluttered #

Twitter

A Flutter package that provides various handy widgets and other helpers to reduce boiler plate code.

Show some ❤️ and star the repo to support the project

GitHub starsGitHub forksGitHub watchers

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

fluttered: <latest_version>

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Donations #

This project needs you! If you would like to support the creator of this project or the continuous development and maintenance of this project, feel free to donate. Your donation is highly appreciated. Thank you!

PayPal

  • Donate $5: Thank's for creating this project, here's a tea (or some juice) for you!
  • Donate $10: Wow, I am amazed. Let me take you to the movies!
  • Donate $15: I really appreciate your work, let's grab some lunch!
  • Donate $25: That's some awesome stuff you did right there, dinner is on me!
  • Donate $50: I really really want to support this project, great job!
  • Donate $100: You are the man! This project saved me hours (if not days) of struggle and hard work, simply awesome!
  • Donate $2799: Go buddy, buy Macbook Pro for yourself!

Of course, you can also choose what you want to donate, all donations are awesome!

How to Contribute #

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request

[0.0.1]

  • PVC architecture added

[0.0.1+1]

  • README file modified

[0.0.2]

  • a dispose parameter added to ImmutablePVCs to cleanup resources.

[0.1.0]

Breaking Change:

  • StatelessMutabalePVC, StatefulMutabalePVC, StatelessImmutabalePVC and StatefulImmutabalePVC are removed. Use MutablePVC and ImmutablePVC instead.

New Features:

  • StatefulWrapper widget added.

[0.2.0]

Breaking Change:

  • onInit parameter changed to initState in StatefulWrapper.

New Features:

  • didUpdateWidget parameter added to StatefulWrapper.

New Widgets:

  • ThemeManager
  • LifecycleManager
  • LandingPageManager

New Services:

  • SharedPrefsService

Others:

  • Utility methods to calculate width and height based on screenSize added.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluttered: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluttered/fluttered.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/widget/pvc.dart. (-1 points)

Analysis of lib/src/widget/pvc.dart reported 2 hints:

line 81 col 7: 'builder' is deprecated and shouldn't be used.

line 160 col 7: 'builder' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (provider).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
provider ^3.0.0+1 3.2.0 4.0.0-dev
shared_preferences ^0.5.3+4 0.5.4+8
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
shared_preferences_platform_interface 1.0.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test