A Flutter package that provides various handy widgets and other helpers to reduce boiler plate code.
Show some ❤️ and star the repo to support the project
dependencies: section of your
pubspec.yaml, add the following line:
Features and bugs #
Please file feature requests and bugs at the issue tracker.
This project needs you! If you would like to support the creator of this project or the continuous development and maintenance of this project, feel free to donate. Your donation is highly appreciated. Thank you!
- Donate $5: Thank's for creating this project, here's a tea (or some juice) for you!
- Donate $10: Wow, I am amazed. Let me take you to the movies!
- Donate $15: I really appreciate your work, let's grab some lunch!
- Donate $25: That's some awesome stuff you did right there, dinner is on me!
- Donate $50: I really really want to support this project, great job!
- Donate $100: You are the man! This project saved me hours (if not days) of struggle and hard work, simply awesome!
- Donate $2799: Go buddy, buy Macbook Pro for yourself!
Of course, you can also choose what you want to donate, all donations are awesome!
How to Contribute #
- Fork it
- Create your feature branch (git checkout -b my-new-feature)
- Commit your changes (git commit -am 'Add some feature')
- Push to the branch (git push origin my-new-feature)
- Create new Pull Request
- PVC architecture added
- README file modified
disposeparameter added to
ImmutablePVCs to cleanup resources.
StatefulImmutabalePVCare removed. Use
- StatefulWrapper widget added.
onInitparameter changed to
didUpdateWidgetparameter added to
- Utility methods to calculate
A new Flutter project.
Getting Started #
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: fluttered: ^0.2.0
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
- Flutter: 1.12.13+hotfix.5
Health issues and suggestions
lib/src/widget/lifecycle_manager.dart. (-43.75 points)
lib/src/widget/lifecycle_manager.dart failed with 2 errors:
line 78 col 12: Case expressions must be constant.
line 78 col 30: The getter 'suspending' isn't defined for the class 'AppLifecycleState'.
lib/src/widget/pvc.dart. (-10.65 points)
lib/src/widget/pvc.dart reported 2 warnings, 2 hints:
line 80 col 12: The parameter 'create' is required. .
line 159 col 12: The parameter 'create' is required. .
line 81 col 7: 'builder' is deprecated and shouldn't be used. will be removed in 4.0.0, use create instead.
line 160 col 7: 'builder' is deprecated and shouldn't be used. Will be removed as part of 4.0.0, use create instead.
lib/src/widget/theme_manager.dart. (-1 points)
lib/src/widget/theme_manager.dart reported 2 hints:
line 40 col 20: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..
line 40 col 46: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..
Maintenance issues and suggestions
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
|Dart SDK||>=2.1.0 <3.0.0|