protoc_plugin 21.1.1 copy "protoc_plugin: ^21.1.1" to clipboard
protoc_plugin: ^21.1.1 copied to clipboard

A protobuf protoc compiler plugin used to generate Dart code.

80
likes
150/ 160
pub points
93%
popularity

We analyzed this package 21 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

132 out of 290 API elements (45.5 %) have documentation comments.

Some symbols that are missing documentation: const_generator, indenting_writer, indenting_writer.IndentingWriter.addAnnotatedBlock, indenting_writer.IndentingWriter.printAnnotated, indenting_writer.IndentingWriter.printlnAnnotated.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:protoc_plugin/protoc.dart that imports:
  • package:protoc_plugin/src/shared.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fixnum ^1.0.0 1.1.0 1.1.0
path ^1.8.0 1.9.0 1.9.0
protobuf ^3.1.0 3.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

80
likes
150
pub points
93%
popularity

Publisher

verified publishergoogle.dev

A protobuf protoc compiler plugin used to generate Dart code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

fixnum, path, protobuf

More

Packages that depend on protoc_plugin