protoc_plugin 20.0.1 copy "protoc_plugin: ^20.0.1" to clipboard
protoc_plugin: ^20.0.1 copied to clipboard

Protoc compiler plugin to generate Dart code

80
likes
110/ 160
pub points
93%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

128 out of 285 API elements (44.9 %) have documentation comments.

Some symbols that are missing documentation: const_generator, indenting_writer, indenting_writer.IndentingWriter.addAnnotatedBlock, indenting_writer.IndentingWriter.printAnnotated, indenting_writer.IndentingWriter.printlnAnnotated.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:protoc_plugin/protoc.dart that imports:
  • package:protoc_plugin/src/linker.dart that imports:
  • package:protoc_plugin/src/code_generator.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: The ability to import 'BytesBuilder' indirectly is deprecated.

lib/src/code_generator.dart:96:13

   ╷
96 │             BytesBuilder(), (BytesBuilder builder, data) => builder..add(data))
   │             ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/code_generator.dart

WARNING: The ability to import 'BytesBuilder' indirectly is deprecated.

lib/src/code_generator.dart:96:30

   ╷
96 │             BytesBuilder(), (BytesBuilder builder, data) => builder..add(data))
   │                              ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/code_generator.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dart_style ^2.0.0 2.3.6 2.3.6
fixnum ^1.0.0 1.1.0 1.1.0
path ^1.8.0 1.9.0 1.9.0
protobuf ^2.0.0 2.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 73.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.8.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
macros - 0.1.0-main.0 0.1.2-main.4
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

80
likes
110
pub points
93%
popularity

Publisher

verified publishergoogle.dev

Protoc compiler plugin to generate Dart code

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

dart_style, fixnum, path, protobuf

More

Packages that depend on protoc_plugin