protoc_plugin 19.3.1 copy "protoc_plugin: ^19.3.1" to clipboard
protoc_plugin: ^19.3.1 copied to clipboard

outdated

Protoc compiler plugin to generate Dart code

79
likes
15/ 160
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 15 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: protoc_plugin,
    • contains a version property, and,
    • does not contain a publish_to property.

protoc_plugin/pubspec.yaml from the repository URL mismatch: expected https://github.com/dart-lang/protobuf but got https://github.com/google/protobuf.dart.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:88:9

   ╷
88 │ <li>Mac <a href="http://brew.sh/">homebrew</a>: <code>brew install protobuf</code></li>
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.4. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.7.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.4.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.7.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

0/20 points: Compatible with dependency constraint lower bounds

dart pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.4) only supports null safety.

For details, see https://dart.dev/null-safety

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

79
likes
15
pub points
93%
popularity

Publisher

verified publishergoogle.dev

Protoc compiler plugin to generate Dart code

Repository (GitHub)
View/report issues

License

BSD-3-Clause (license)

Dependencies

dart_style, fixnum, path, protobuf

More

Packages that depend on protoc_plugin