protic 0.1.3+1

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate protic

2. Use it

The package has the following executables:


$ protic

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  protic: ^0.1.3+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:protic/protic.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
20
Overall:
Weighted score of the above. [more]
22
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4

Health issues and suggestions

Fix lib/src/js/entrypoint.dart. (-99.90 points)

Analysis of lib/src/js/entrypoint.dart failed with 24 errors, 10 hints, including:

line 1 col 1: Undefined name 'JS' used as an annotation.

line 4 col 8: Target of URI doesn't exist: 'package:js/js.dart'.

line 5 col 8: Target of URI doesn't exist: 'package:js/js_util.dart'.

line 11 col 1: Undefined name 'JS' used as an annotation.

line 16 col 1: Undefined name 'JS' used as an annotation.

Fix lib/src/js/node_io.dart. (-92.49 points)

Analysis of lib/src/js/node_io.dart failed with 9 errors, including:

line 1 col 1: Undefined name 'JS' used as an annotation.

line 4 col 8: Target of URI doesn't exist: 'package:js/js.dart'.

line 6 col 1: Undefined name 'JS' used as an annotation.

line 9 col 1: Undefined name 'JS' used as an annotation.

line 12 col 1: Undefined name 'JS' used as an annotation.

Document public APIs. (-1 points)

23 out of 23 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/compiler.dart. (-10.89 points)

Analysis of lib/src/compiler.dart reported 23 hints, including:

line 49 col 8: Don't explicitly initialize variables to null.

line 58 col 16: Unnecessary new keyword.

line 69 col 41: Use = to separate a named parameter from its default value.

line 152 col 15: Unnecessary new keyword.

line 157 col 14: Unnecessary new keyword.

Fix additional 7 files with analysis or formatting issues. (-18 points)

Additional issues in the following files:

  • lib/src/expression.dart (18 hints)
  • lib/src/html_parsing.dart (10 hints)
  • lib/src/platform/node.dart (4 hints)
  • lib/src/platform/vm.dart (4 hints)
  • lib/src/driver.dart (1 hint)
  • lib/src/api.dart (Run dartfmt to format lib/src/api.dart.)
  • lib/src/platform.dart (Run dartfmt to format lib/src/platform.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and protic.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
args ^1.5.2 1.5.2
collection ^1.14.11 1.14.12
html ^0.14.0 0.14.0+3
petitparser ^2.4.0 2.4.0
source_maps ^0.10.8 0.10.8
source_span ^1.5.5 1.5.5
Transitive dependencies
charcode 1.1.2
csslib 0.16.1
meta 1.1.8
path 1.6.4
term_glyph 1.1.0
Dev dependencies
js ^0.6.1
node_preamble ^1.4.6
test ^1.6.8