process_run 0.10.10
process_run: ^0.10.10 copied to clipboard

Process run helpers for Linux/Win/Mac and which like feature for finding executables.

82
likes
100/ 130
pub points
96%
popularity

We analyzed this package on Oct 15, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 62 out of 136 API elements (45.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:process_run/process_run.dart that imports:
  • package:process_run/src/dev_process_run.dart that imports:
  • package:process_run/cmd_run.dart that imports:
  • package:process_run/src/flutterbin_cmd.dart that imports:
  • package:process_run/src/process_cmd.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=1.5.0 <3.0.02.3.02.3.0
collection>=1.14.10 <3.0.01.15.01.15.0
io>=0.3.0 <2.0.01.0.31.0.3
meta>=1.1.0 <3.0.01.7.01.7.0
path>=1.6.1 <3.0.01.8.01.8.0
pub_semver>=1.4.0 <3.0.02.1.02.1.0
yaml>=2.0.0 <4.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

82
likes
100
pub points
96%
popularity

Publisher

tekartik.com

Process run helpers for Linux/Win/Mac and which like feature for finding executables.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

args, collection, io, meta, path, pub_semver, yaml

More

Packages that depend on process_run