prixa_plugin 0.0.1-beta copy "prixa_plugin: ^0.0.1-beta" to clipboard
prixa_plugin: ^0.0.1-beta copied to clipboard

Simple Mini Test

0
likes
80/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 7 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: prixa_plugin, prixa_plugin.PrixaPage, prixa_plugin.PrixaPage.PrixaPage, prixa_plugin.PrixaPlugin, prixa_plugin.PrixaPlugin.PrixaPlugin.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
Package does not support platform `iOS`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
Package does not support platform `Windows`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
Package does not support platform `Linux`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
Package does not support platform `macOS`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
Package does not support platform `Web`.

Because:

  • package:prixa_plugin/prixa_plugin.dart that declares support for platforms: .
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/prixa_plugin.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

0
likes
80
pub points
0%
popularity

Publisher

unverified uploader

Simple Mini Test

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on prixa_plugin