powers 1.0.0 icon indicating copy to clipboard operation
powers: ^1.0.0 copied to clipboard

Extension methods for the num (int and double) class that adds functionality for finding the square, cube, and higher order roots and powers of the number.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add powers

With Flutter:

 $ flutter pub add powers

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  powers: ^1.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:powers/powers.dart';
2
likes
110
pub points
74%
popularity

Publisher

verified publisher iconjamesalex.dev

Extension methods for the num (int and double) class that adds functionality for finding the square, cube, and higher order roots and powers of the number.

Repository (GitHub)
View/report issues

License

BSD-2-Clause (LICENSE)

More

Packages that depend on powers