powerdart 0.0.2
powerdart: ^0.0.2 copied to clipboard

Compute the Power Spectral Density (PSD) on Dart. This package runs everywhere dart runs.

0
likes
90 / 110
pub points
25 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 17 API elements (58.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/dft/dft.dart:12:13

   ╷
12 │   var out = List<Complex>(n);
   │             ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dft/dft.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/psd_analysis/cumtrapz.dart:16:13

   ╷
16 │   final b = List<double>(y.length - 1);
   │             ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/psd_analysis/cumtrapz.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
complex^0.5.00.5.00.7.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on complex does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions complex to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
90
pub points
25%
popularity

Compute the Power Spectral Density (PSD) on Dart. This package runs everywhere dart runs.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

djonline96@gmail.com

License

BSD (LICENSE)

Dependencies

complex

More

Packages that depend on powerdart