posthog_flutter 1.11.2
posthog_flutter: ^1.11.2 copied to clipboard

Flutter Android iOS web

Flutter implementation of Posthog client for iOS, Android and Web

2
likes
90 / 110
pub points
46 %
popularity

We analyzed this package on Jan 23, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 27 API elements (14.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:posthog_flutter/posthog_flutter.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'messenger' is deprecated and shouldn't be used. This property is redundant. It returns the object on which it is called. This feature was deprecated after v1.24.0-7.0.pre..

lib/src/posthog_web.dart:11:17

   ╷
11 │       registrar.messenger,
   │                 ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/posthog_web.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.0.01.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
js-0.6.3-nullsafety.30.6.3-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
90
pub points
46%
popularity

Flutter implementation of Posthog client for iOS, Android and Web

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

james.g@posthog.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins, meta

More

Packages that depend on posthog_flutter