pos_printer_bloc 0.1.4
pos_printer_bloc: ^0.1.4 copied to clipboard

A Flutter BLoC component to uniformly handle printing of POS receipts.

1
likes
50 / 130
pub points
23 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +80 ms] executing: uname -m
[  +38 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +7 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +7 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] f4abaa0735eba4dfd8f33f73363911d63931fe03
[        ] executing: [/tool/stable/flutter/] git tag --points-at f4abaa0735eba4dfd8f33f73363911d63931fe03
[  +14 ms] Exit code 0 from: git tag --points-at f4abaa0735eba4dfd8f33f73363911d63931fe03
[        ] 2.2.3
[   +7 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +6 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +57 ms] Unable to locate an Android SDK.
[   +9 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +5 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +56 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[   +9 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/pub upgrade --verbose
MSG : Resolving dependencies...
[+1295 ms] "flutter pub" took 1,387ms.
[   +2 ms] ensureAnalyticsSent: 0ms
[   +1 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1
stderr: FINE: Pub 2.13.4
SLVR: fact: pos_printer_bloc is 0.1.4
SLVR: derived: pos_printer_bloc
SLVR: fact: pos_printer_bloc depends on equatable ^1.2.0
SLVR: fact: pos_printer_bloc depends on esc_pos_bluetooth ^0.2.8
SLVR: fact: pos_printer_bloc depends on esc_pos_printer ^3.2.5
SLVR: fact: pos_printer_bloc depends on esc_pos_utils ^0.4.1
SLVR: fact: pos_printer_bloc depends on flutter any from sdk
SLVR: fact: pos_printer_bloc depends on flutter_bloc ^6.0.1
SLVR: fact: pos_printer_bloc depends on flutter_bluetooth_basic ^0.1.5
SLVR: fact: pos_printer_bloc depends on flutter_star_prnt ^1.0.4
SLVR: fact: pos_printer_bloc depends on image ^2.1.14
SLVR: fact: pos_printer_bloc depends on shared_preferences ^0.5.7
SLVR: fact: pos_printer_bloc depends on validators ^2.0.1
SLVR:   selecting pos_printer_bloc
SLVR:   derived: validators ^2.0.1
SLVR:   derived: shared_preferences ^0.5.7
SLVR:   derived: image ^2.1.14
SLVR:   derived: flutter_star_prnt ^1.0.4
SLVR:   derived: flutter_bluetooth_basic ^0.1.5
[...]
           #3      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1043:27)
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:196:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:284:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:232:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:91:3)
           <asynchronous suspension>


Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/bloc/printer_bloc.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/bloc/printer_scan_bloc.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
Because esc_pos_bluetooth >=0.2.8 depends on esc_pos_utils ^0.3.6 and pos_printer_bloc depends on esc_pos_utils ^0.4.1, esc_pos_bluetooth >=0.2.8 is forbidden.
So, because pos_printer_bloc depends on esc_pos_bluetooth ^0.2.8, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.