popcorn_api 1.1.5
popcorn_api: ^1.1.5 copied to clipboard

Dart native
Flutter Android iOS

An easy way to get data from the Popcorn Time API. Documentation is available at https://popcorn-api.js.org/

0
likes
75 / 110
pub points
0 %
popularity

We analyzed this package on Jan 22, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

CHANGELOG.md is empty.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:popcorn_api/src/Popcorn.dart that imports:
  • package:popcorn_api/src/structures/Routers.dart that imports:
  • package:popcorn_api/src/utils/request.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/Popcorn.dart:5:11

  ╷
5 │    return new Routers("movies");
  │           ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Popcorn.dart

INFO: Unnecessary new keyword.

lib/src/Popcorn.dart:8:11

  ╷
8 │    return new Routers("animes");
  │           ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Popcorn.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
meta-1.2.41.2.4
path-1.7.01.7.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
75
pub points
0%
popularity

An easy way to get data from the Popcorn Time API. Documentation is available at https://popcorn-api.js.org/

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

acnologla2121@gmail.com

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on popcorn_api