polylingual 0.0.2

Flutter Android iOS

PolyLingual is a plug-in that provides a means of storing and updating String translations for a Flutter app via a simple JSON file.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Oct 31, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 11 API elements (45.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:polylingual/polylingual.dart that imports:
  • package:polylingual/src/translator.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:polylingual/polylingual.dart that imports:
  • package:polylingual/src/translator.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:polylingual/polylingual.dart that imports:
  • package:polylingual/src/translator.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:polylingual/polylingual.dart that imports:
  • package:polylingual/src/translator.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path_provider^0.5.00.5.0+11.6.22
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on path_provider does not support the latest published version `1.6.22`

pubspec.yaml:13:18

   ╷
13 │   path_provider: ^0.5.0
   │                  ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

PolyLingual is a plug-in that provides a means of storing and updating String translations for a Flutter app via a simple JSON file.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

srogers.uk@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, path_provider

More

Packages that depend on polylingual