pointpos_api 0.2.1
pointpos_api: ^0.2.1 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

PointPOS API client

0
likes
80 / 110
pub points
32 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 423 out of 1845 API elements (22.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 768 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/api.dart:295:5

    ╷
295 │ ┌     /**
296 │ │     * Add custom global interceptors, put overrideInterceptors to true to set your interceptors only (auth interceptors will not be added)
297 │ └     */
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/api.dart

INFO: Prefer using /// for doc comments.

lib/api.dart:329:5

    ╷
329 │ ┌     /**
330 │ │     * Get AdjustmentStockApi instance, base route and serializer can be overridden by a given but be careful,
331 │ │     * by doing that all interceptors will not be executed
332 │ └     */
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/api.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.10.12.20.13.0
jaguar_mimetype^1.0.11.0.11.0.1
jaguar_retrofit^2.8.82.8.82.8.8
jaguar_serializer^2.2.122.2.122.2.12
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
auth_header-2.1.42.1.4
charcode-1.2.01.2.0
client_cookie-2.2.12.2.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
jaguar_resty-2.10.152.10.15
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`, that was published 25 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

0
likes
80
pub points
32%
popularity

Publisher

pointbyte.id

PointPOS API client

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, jaguar_mimetype, jaguar_retrofit, jaguar_serializer

More

Packages that depend on pointpos_api