pointer_interceptor 0.10.1 copy "pointer_interceptor: ^0.10.1" to clipboard
pointer_interceptor: ^0.10.1 copied to clipboard

PlatformiOSweb

A widget to prevent clicks from being swallowed by underlying HtmlElementViews on the web.

199
likes
140/ 140
pub points
99%
popularity

We analyzed this package 44 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+pointer_interceptor%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 11 API elements (90.9 %) have documentation comments.

Some symbols that are missing documentation: pointer_interceptor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
Package does not support platform `Windows`.

Because:

  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
pointer_interceptor_ios ^0.10.0 0.10.0+2 0.10.0+2
pointer_interceptor_platform_interface ^0.10.0 0.10.0+1 0.10.0+1
pointer_interceptor_web ^0.10.0 0.10.2 0.10.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.