plugin_platform_interface 2.0.0
plugin_platform_interface: ^2.0.0 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows
unlisted

Reusable base class for Flutter plugin platform interfaces.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  plugin_platform_interface: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:plugin_platform_interface/plugin_platform_interface.dart';
14
likes
90
pub points
100%
popularity

Publisher

flutter.dev

Reusable base class for Flutter plugin platform interfaces.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

meta

More

Packages that depend on plugin_platform_interface