plotly 0.7.3

  • Readme
  • Changelog
  • Installing
  • 23

plotly.dart #

A Dart interface to plotly.js, plotly.dart is a high-level, declarative charting library.

Usage #

var trace = {
  'x': [1, 2, 3, 4],
  'y': [10, 15, 13, 17],
  'mode': 'markers'
};

var layout = {
  'title': 'Scatter Plot',
  'height': 800,
  'width': 960
};

new plotly.Plot.id('myDiv', [trace], layout);

Changelog #

0.7.3 #

  • Updated plotly version (1.26.1) official

0.7.2 #

  • Updated plotly version to latests (1.25.2)

0.7.1+2 #

  • Added purge method

0.7.1+1 #

  • Fixed deleteFrames method

0.7.1 #

  • Added support for animations

0.7.0 #

  • Added support for plotly 1.24.0

0.0.6+2 #

  • Fixed map and lists jsify

0.0.6+1 #

  • Fixed addTraces

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  plotly: ^0.7.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:plotly/plotly.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
23
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.