platform_widgets 0.1.1
platform_widgets: ^0.1.1 copied to clipboard

A Flutter plugin for Platform widgets. This package simplifies the usage of specific widgets for both Android and iOS.

6
likes
60 / 130
pub points
48 %
popularity

We analyzed this package on May 12, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 116 API elements (9.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:platform_widgets/base/platform_app.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

ERROR: Classes can only extend other classes.

lib/base/platform_theme.dart:5:29

  ╷
5 │ class PlatformTheme extends Diagnosticable {
  │                             ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/base/platform_theme.dart

ERROR: The named parameter 'actionsForegroundColor' isn't defined.

lib/platform_bar.dart:74:7

   ╷
74 │       actionsForegroundColor: cupertinoActionsForegroundColor,
   │       ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/platform_bar.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

6
likes
60
pub points
48%
popularity

Publisher

flutterista.dev

A Flutter plugin for Platform widgets. This package simplifies the usage of specific widgets for both Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on platform_widgets