platform_aware 0.4.0
platform_aware: ^0.4.0

Flutter Android iOS web

Flutter widgets providing a native look on both Android and iOS.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Nov 22, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.com/jmgprog/platform_aware was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 110 API elements (4.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Missing case clause for 'linux'.

lib/src/platform_aware_widget.dart:12:5

   ╷
12 │     switch (Theme.of(context).platform) {
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/platform_aware_widget.dart

WARNING: Missing case clause for 'macOS'.

lib/src/platform_aware_widget.dart:12:5

   ╷
12 │     switch (Theme.of(context).platform) {
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/platform_aware_widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
The current Dart SDK version is 2.12.0-51.0.dev.

Because platform_aware depends on test >=0.12.0-beta.3 <1.3.0 which requires SDK version >=1.8.0 <2.0.0-∞, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

Flutter widgets providing a native look on both Android and iOS.

Repository (GitLab)
View/report issues

Documentation

API reference

Uploader

jan@jmgprog.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on platform_aware