persistent_canvas 1.0.5+5
persistent_canvas: ^1.0.5+5 copied to clipboard

Provides PersistentCanvas and PixelBuffer via PhotographTransducer

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 19, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 178 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:persistent_canvas/persistent_canvas.dart that imports:
  • package:persistent_canvas/photograph_transducer.dart that imports:
  • package:busy_model/busy_model.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/persistent_canvas.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/persistent_canvas_stack.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
busy_model^1.0.01.0.0+01.0.0+0
flutterflutter0.0.00.0.0
image^2.0.82.1.193.0.8
scoped_model^1.0.11.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
meta-1.7.01.7.0
path-1.8.01.8.0
petitparser-3.1.04.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.8` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
70
pub points
0%
popularity

Provides PersistentCanvas and PixelBuffer via PhotographTransducer

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

busy_model, flutter, image, scoped_model

More

Packages that depend on persistent_canvas