pen_api 0.2.3

  • Readme
  • Changelog
  • Installing
  • 19

pen_api #

A programmatic API for pen. (a pubspec authoring tool)

This is intended for programatically handling the pubspec.yaml files of your packages with the development aid (and/or automatization) in mind.

Just go to the docs and begin!

Forked from den_api

0.1.2 #

  • README.md improvements
  • CHANGELOG.md maintenance
  • fixed bug in tests

0.1.1 #

  • fork from den_api original package

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pen_api: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pen_api/pen_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
19
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: Because every version of github from git depends on http ^0.12.0 and every version of pub_package_data2 depends on http ^0.11.3+17, github from git is incompatible with pub_package_data2.
 So, because pen_api depends on both pub_package_data2 ^0.2.0 and github from git, version solving failed.

Health suggestions

Format lib/pen_api.dart.

Run dartfmt to format lib/pen_api.dart.

Format lib/src/bump.dart.

Run dartfmt to format lib/src/bump.dart.

Format lib/src/github_repo_description.dart.

Run dartfmt to format lib/src/github_repo_description.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/package_dep.dart (Run dartfmt to format lib/src/package_dep.dart.)
  • lib/src/release_type.dart (Run dartfmt to format lib/src/release_type.dart.)
  • lib/src/yaml_edit.dart (Run dartfmt to format lib/src/yaml_edit.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Package is getting outdated. (-26.85 points)

The package was last published 66 weeks ago.

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and pen_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.60.2 <3.0.0