Provides data about packages published to pub.dartlang.org.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: pub_package_data2: ^0.2.0
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.6.1
- pana: 0.13.1+4
lib/pub_package_data.dart. (-9.54 points)
lib/pub_package_data.dart reported 20 hints, including:
line 14 col 1: Prefer using /// for doc comments.
line 26 col 1: Prefer using /// for doc comments.
line 39 col 17: Unnecessary new keyword.
line 50 col 16: Unnecessary new keyword.
line 53 col 47: Unnecessary new keyword.
lib/src/package_list.dart. (-0.50 points)
lib/src/package_list.dart reported 1 hint:
line 4 col 21: Avoid const keyword.
Maintenance issues and suggestions
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
Package is getting outdated. (-26.58 points)
The package was last published 66 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
pub_package_data2.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=1.8.0 <3.0.0|