peek_and_pop 1.0.3
peek_and_pop: ^1.0.3 copied to clipboard

Peek & Pop implementation for Flutter based on the iOS functionality of the same name.

43
likes
80 / 130
pub points
57 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.cosmossoftware.coffee was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 205 out of 452 API elements (45.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/animated_cross_fade.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/gesture_detector.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^2.0.02.0.07.0.0
flutterflutter0.0.00.0.0
snap^1.0.41.0.62.0.0
transparent_image^1.0.01.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flick-1.0.4+12.0.0
meta-1.3.01.4.0
rxdart-0.22.60.27.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.0` on bloc does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^1.0.4` on snap does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions snap to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

43
likes
80
pub points
57%
popularity

Publisher

cosmossoftware.coffee

Peek & Pop implementation for Flutter based on the iOS functionality of the same name.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, flutter, snap, transparent_image

More

Packages that depend on peek_and_pop