Do you ever want to
pub build into another branch? This is your ticket.
$ pub global activate peanut
$ cd ~/my_dart_proj/ $ peanut
This will build your project into a temporary directory, and then it will update the local
gh-pages branch with its contents.
The easiest way to push your
gh-pages branch to github (without switching from your working branch) is:
$ git push origin --set-upstream gh-pages
To create (or update) your local
gh-pages branch to match what's on the server.
$ git update-ref refs/heads/gh-pages origin/gh-pages
This is also useful if you want to undo a
$ peanut --help -d, --directory (defaults to "web") -b, --branch (defaults to "gh-pages") --mode The mode to run `pub build` in. [release (default), debug] -c, --build-config The configuration to use when running `build_runner`. If this option is not set, `release` is used if `build.release.yaml` exists in the current directory. -m, --message (defaults to "Built <directory>") -t, --build-tool If `build.release.yaml` exists in the current directory, defaults to "build". Otherwise, "pub". [pub (default), build] -h, --help
/binso it's not activated during
pub global activate.
pub from the SDK invoking
peanut. Also fixes the case where
not in the user's PATH.
Send all output to
Improve exit codes and error messages on failure.
**.ng_placeholderto the set of files to exclude.
Only warn if the
directory does not exist. Build could still work.
Update dependency on
pkg:git. Allows running
peanut in a subdirectory of
a Git repository.
Improve sub-process management.
Print error/warnings in red – where supported.
Initial support for
Updated Dart SDK lower-bound to
Iterable.whereType<T> – introduced in this release.
pub buildto run in debug mode.
runInShellto make things work on Windows.
You can install the package from the command line:
$ pub global activate peanut
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: peanut: ^1.1.6
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|3.2.1||May 22, 2019|
|3.2.0||May 6, 2019|
|3.1.1||May 3, 2019|
|3.1.0||May 1, 2019|
|3.0.3||Apr 25, 2019|
|3.0.2||Apr 24, 2019|
|3.0.1||Apr 23, 2019|
|3.0.0||Apr 23, 2019|
|2.0.8||Dec 11, 2018|
|2.0.7||Sep 27, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0-dev.22 <2.0.0|