paygilant_plugin 2.2.40 icon indicating copy to clipboard operation
paygilant_plugin: ^2.2.40 copied to clipboard

Paygilant Plugin exposes a dart interface, which wraps the native SDK, and enables a smooth integration with the Flutter development environment.

0
likes
100/ 140
pub points
27%
popularity

We analyzed this package 10 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 159 out of 486 API elements (32.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:paygilant_plugin/paygilant_plugin.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform Linux.

Because:

  • package:paygilant_plugin/paygilant_plugin.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform macOS.

Because:

  • package:paygilant_plugin/paygilant_plugin.dart that declares support for platforms: Android, iOS, Web.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The import of 'dart:async' is unnecessary because all of the used elements are also provided by the import of 'dart:core'.

lib/paygilant_plugin.dart:1:8

  ╷
1 │ import 'dart:async';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/paygilant_plugin.dart

INFO: Unused import: 'package:flutter/cupertino.dart'.

lib/paygilant_plugin.dart:4:8

  ╷
4 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/paygilant_plugin.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
100
pub points
27%
popularity

Publisher

unverified uploader

Paygilant Plugin exposes a dart interface, which wraps the native SDK, and enables a smooth integration with the Flutter development environment.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on paygilant_plugin