path 1.3.7
path: ^1.3.7 copied to clipboard

outdatedDart 2 incompatible

A string-based path manipulation library. All of the path operations you know and love, with solid support on both Windows and POSIX (Linux and Mac OS X) machines.

1.3.7 #

  • Improve the performance of absolute() and normalize().

1.3.6 #

  • Ensure that path.toUri preserves trailing slashes for relative paths.

1.3.5 #

  • Added type annotations to top-level and static fields.

1.3.4 #

  • Fix dev_compiler warnings.

1.3.3 #

  • Performance improvement in Context.relative - don't call current if from is not relative.

1.3.2 #

  • Fix some analyzer hints.

1.3.1 #

  • Add a number of performance improvements.

1.3.0 #

  • Expose a top-level context field that provides access to a Context object for the current system.

1.2.3 #

  • Don't cache path Context based on cwd, as cwd involves a system-call to compute.

1.2.2 #

  • Remove the documentation link from the pubspec so this is linked to pub.dartlang.org by default.

1.2.1 #

  • Many members on Style that provided access to patterns and functions used internally for parsing paths have been deprecated.

  • Manually parse paths (rather than using RegExps to do so) for better performance.

1.2.0 #

  • Added path.prettyUri, which produces a human-readable representation of a URI.

1.1.0 #

  • path.fromUri now accepts strings as well as Uri objects.
616
likes
0
pub points
100%
popularity

Publisher

dart.dev

A string-based path manipulation library. All of the path operations you know and love, with solid support on both Windows and POSIX (Linux and Mac OS X) machines.

Repository
View/report issues

License

unknown (LICENSE)

More

Packages that depend on path