passwordmicrointeraction 0.0.1
passwordmicrointeraction: ^0.0.1 copied to clipboard

A basic micro interaction plugin for password fields.

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.iamlimitless19.com was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 13 API elements (53.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:passwordmicrointeraction/passwordmicrointeraction.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/passwordmicrointeraction.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/bloc/login_bloc.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
email_validator^1.0.01.0.62.0.1
flutterflutter0.0.00.0.0
fluttertoast^3.1.33.1.38.0.8
rxdart^0.22.60.22.60.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on email_validator does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions email_validator to update the constraint.

The constraint `^3.1.3` on fluttertoast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions fluttertoast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
70
pub points
0%
popularity

Publisher

iamlimitless19.com

A basic micro interaction plugin for password fields.

Homepage (missing)

Documentation

API reference

License

MIT (LICENSE)

Dependencies

email_validator, flutter, fluttertoast, rxdart

More

Packages that depend on passwordmicrointeraction