password_rule_check 0.2.1 copy "password_rule_check: ^0.2.1" to clipboard
password_rule_check: ^0.2.1 copied to clipboard

A Flutter Widget to display if a password matches given Rules

2
likes
130/ 140
pub points
47%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 66 API elements (81.8 %) have documentation comments.

Some symbols that are missing documentation: password_rule_check, password_rule_check.PasswordRuleCheck, password_rule_check.PasswordRuleCheck.PasswordRuleCheck, password_rule_check.PasswordRuleCheck.PasswordRuleCheck.suggestedSafety, password_rule_check.PasswordRuleCheckState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/translations/de.dart:2:1

  ╷
2 │ part of password_rule_check_translations;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/translations/de.dart

INFO: The part-of directive uses a library name.

lib/src/translations/en.dart:2:1

  ╷
2 │ part of password_rule_check_translations;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/translations/en.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

2
likes
130
pub points
47%
popularity

Publisher

verified publisherzweidenker.de

A Flutter Widget to display if a password matches given Rules

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on password_rule_check