pano_rtc 1.0.7 copy "pano_rtc: ^1.0.7" to clipboard
pano_rtc: ^1.0.7 copied to clipboard

Flutter plugin for PanoRtc SDK.

1
likes
120/ 140
pub points
59%
popularity

We analyzed this package 10 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

860 out of 862 API elements (99.8 %) have documentation comments.

Some symbols that are missing documentation: pano_rtc, pano_rtc.RtcGroupManager.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:pano_rtc/pano_rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:pano_rtc/pano_rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:pano_rtc/pano_rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:pano_rtc/pano_rtc.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 119 issues. Showing the first 2:

INFO: The declaration '_$ResultCodeConverterFromJson' isn't referenced.

lib/src/enum_converter.g.dart:9:21

  ╷
9 │ ResultCodeConverter _$ResultCodeConverterFromJson(Map<String, dynamic> json) =>
  │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/enum_converter.g.dart

INFO: The declaration '_$ResultCodeConverterToJson' isn't referenced.

lib/src/enum_converter.g.dart:14:22

   ╷
14 │ Map<String, dynamic> _$ResultCodeConverterToJson(
   │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/enum_converter.g.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.4.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.