pagarme_flutter_card_hash 0.2.0

Flutter Android iOS web

A Flutter package that allows you to generate card hashes to be used with Pagar.me's payment platform.

1
likes
90 / 110
pub points
52 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 87 API elements (6.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.93.0.103.0.10
encrypt^3.3.13.3.14.0.3
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
asn1lib-0.5.150.8.1
characters-1.0.01.0.0
charcode-1.1.31.1.3
clock-1.0.11.0.1
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
http_parser-3.1.43.1.4
meta-1.1.81.2.3
path-1.7.01.7.0
pointycastle-1.0.21.0.2
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.3.1` on encrypt does not support the latest published version `4.0.3`

pubspec.yaml:13:12

   ╷
13 │   encrypt: ^3.3.1
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
90
pub points
52%
popularity

A Flutter package that allows you to generate card hashes to be used with Pagar.me's payment platform.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

charlesaquino1992@gmail.com

License

BSD (LICENSE)

Dependencies

dio, encrypt, flutter

More

Packages that depend on pagarme_flutter_card_hash