paddinger 0.2.0 copy "paddinger: ^0.2.0" to clipboard
paddinger: ^0.2.0 copied to clipboard

Code generation for Flutter Padding widgets based on your constants.

18
likes
130/ 140
pub points
23%
popularity

We analyzed this package 16 hours ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/ema987/paddinger was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 2 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: paddinger.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:paddinger/paddinger.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:paddinger/paddinger.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:paddinger/paddinger.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^2.1.0 2.8.0 6.4.1
build ^2.1.0 2.4.1 2.4.1
paddinger_annotations ^0.2.0 0.2.0 0.2.0
recase ^4.0.0 4.1.0 4.1.0
source_gen ^1.1.0 1.2.2 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 31.0.0 67.0.0
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
cli_util - 0.3.5 0.4.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.2.1 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.0` on analyzer does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

18
likes
130
pub points
23%
popularity

Publisher

verified publisheremanuelepapa.dev

Code generation for Flutter Padding widgets based on your constants.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, paddinger_annotations, recase, source_gen

More

Packages that depend on paddinger