owo 1.0.6
owo: ^1.0.6 copied to clipboard

API Wrapper for https://whats-th.is/

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/owo_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 23 API elements (56.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:owo/owo.dart that imports:
  • package:owo/src/utils/functions.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/owo.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/core/errors/exceptions.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartz^0.9.00.9.20.10.0
http^0.12.10.12.20.13.3
meta^1.1.81.7.01.7.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.9.0` on dartz does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions dartz to update the constraint.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Dart 2.14.0.

1
likes
70
pub points
0%
popularity

Publisher

metaboy.info

API Wrapper for https://whats-th.is/

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dartz, http, meta, yaml

More

Packages that depend on owo