otpauth_migration 0.0.7 copy "otpauth_migration: ^0.0.7" to clipboard
otpauth_migration: ^0.0.7 copied to clipboard

A Dart package to encode and decode the otpauth-migration URI format used to import into and export 2FA secrets from the Google Authenticator app.

5
likes
120/ 140
pub points
56%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 4 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/generated/GoogleAuthenticatorImport.pb.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generated/GoogleAuthenticatorImport.pb.dart

INFO: Dangling library doc comment.

lib/generated/GoogleAuthenticatorImport.pbenum.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generated/GoogleAuthenticatorImport.pbenum.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fixnum ^1.0.0 1.1.0 1.1.0
protobuf ^2.0.1 2.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

5
likes
120
pub points
56%
popularity

Publisher

verified publisherquiznoob.app

A Dart package to encode and decode the otpauth-migration URI format used to import into and export 2FA secrets from the Google Authenticator app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

fixnum, protobuf

More

Packages that depend on otpauth_migration