otp 2.2.3
otp: ^2.2.3 copied to clipboard

RFC6238 Time-Based One-Time Password / Google Authenticator Library

32
likes
90 / 130
pub points
90 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 18 API elements (83.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/otp.dart:165:21

    ╷
165 │     final newList = List<int>();
    │                     ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/otp.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
base32>=1.1.1 <2.0.01.1.21.1.2
convert>=2.0.0 <3.0.02.1.13.0.0
crypto>=2.1.3 <3.0.02.1.53.0.1
quick_log>=1.0.0 <2.0.01.1.45.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
args-2.1.02.1.0
async-2.6.12.6.1
boolean_selector-2.1.02.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
coverage-0.15.21.0.2
file-6.1.06.1.0
glob-2.0.12.0.1
hasura-1.5.01.5.0
hive-1.4.4+12.0.4
http-0.12.20.13.3
http_multi_server-3.0.13.0.1
http_parser-3.1.44.0.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
no_bloc-0.7.00.13.4
node_preamble-1.4.132.0.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
rxdart-0.27.00.27.0
shelf-0.7.91.1.2
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
test_api-0.2.190.4.0
test_core-0.3.150.3.23
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vm_service-6.2.06.2.0
watcher-1.0.01.0.0
web_socket_channel-1.2.02.1.0
webkit_inspection_protocol-1.0.01.0.0
websocket-0.0.50.0.5
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=2.0.0 <3.0.0` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `>=2.1.3 <3.0.0` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

32
likes
90
pub points
90%
popularity

Publisher

yuli.dev

RFC6238 Time-Based One-Time Password / Google Authenticator Library

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

base32, convert, crypto, quick_log

More

Packages that depend on otp