osx_kvm_installer 1.0.8
osx_kvm_installer: ^1.0.8 copied to clipboard

A cli based application which automates the installation and installation preperation steps required for the OSX-KVM project.

7
likes
90/ 130
pub points
0%
popularity

We analyzed this package 6 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:osx_kvm_installer/osx_kvm_installer.dart that imports:
  • package:osx_kvm_installer/src/install.dart that imports:
  • package:osx_kvm_installer/src/installation_preparation.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • package:dcli/src/util/stack_trace_impl.dart that imports:
  • package:dcli/src/settings.dart that imports:
  • package:dcli/src/functions/env.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.0.01.6.02.3.0
dcli^0.24.00.24.11.14.1
meta^1.2.21.7.01.7.0
path^1.0.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
async-2.8.22.8.2
basic_utils-2.7.13.9.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csv-4.1.05.0.1
equatable-1.2.62.0.3
file-5.2.16.1.2
file_utils-0.1.41.0.1
glob-1.2.02.0.2
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
ini-2.1.02.1.0
intl-0.16.10.17.0
js-0.6.30.6.3
json_annotation-3.1.14.4.0
logger-0.9.41.1.0
logging-0.11.41.0.2
matcher-0.12.110.12.11
money2-1.4.33.0.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
pointycastle-2.0.13.4.0
pub_semver-1.4.42.1.0
pubspec-0.1.52.0.1
quiver-2.1.53.0.1+1
random_string-2.3.12.3.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
system_info-0.1.31.0.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.5
validators-2.0.13.0.0
vin_decoder-0.1.4+10.1.4+1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.24.0` on dcli does not support the stable version `0.25.0`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

7
likes
90
pub points
0%
popularity

A cli based application which automates the installation and installation preperation steps required for the OSX-KVM project.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

args, dcli, meta, path

More

Packages that depend on osx_kvm_installer