os 0.1.2
os: ^0.1.2 copied to clipboard

Dart native
Flutter Android iOS

Access to operating system APIs (using 'dart:ffi'). Virtual memory management, IPC pipes, file permissions, etc.

4
likes
90 / 110
pub points
32 %
popularity

We analyzed this package on Jan 22, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 39 API elements (30.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:os/file_system.dart that imports:
  • package:os/src/file_system/named_pipe.dart that imports:
  • package:os/src/libc/all.dart that imports:
  • package:os/src/libc/functions.dart that imports:
  • package:os/loading.dart that imports:
  • package:os/src/loading/loading.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Unused import: 'dart:ffi'.

lib/src/file_system/misc.dart:16:8

   ╷
16 │ import 'dart:ffi' as ffi;
   │        ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/file_system/misc.dart

INFO: Unused import: 'package:ffi/ffi.dart'.

lib/src/virtual_memory/virtual_memory.dart:19:8

   ╷
19 │ import 'package:ffi/ffi.dart' as ffi;
   │        ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/virtual_memory/virtual_memory.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.30.1.3
meta^1.1.01.2.41.2.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
90
pub points
32%
popularity

Access to operating system APIs (using 'dart:ffi'). Virtual memory management, IPC pipes, file permissions, etc.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

terrier989@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

ffi, meta

More

Packages that depend on os