origami_database 0.0.5
origami_database: ^0.0.5 copied to clipboard

database module origami core framework

0
likes
55/ 130
pub points
21%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 157 API elements (0.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:origami_database/database.dart that imports:
  • package:origami_database/service/mongoIndex.dart that imports:
  • package:origami_database/service/databaseIndex.dart that imports:
  • package:origami_database/models/odataModel.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/database.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/models/actionModel.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
mongo_dart^0.4.00.4.40.7.4
origamicore^0.0.30.0.80.0.8
process_run^0.11.2+80.11.2+80.12.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.22.8.2
basic_utils-2.7.13.9.1
bson-0.3.41.0.4
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
io-1.0.31.0.3
json_annotation-3.1.14.3.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mongo_dart_query-0.4.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
pointycastle-2.0.13.4.0
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
rational-0.3.81.2.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on mongo_dart does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions mongo_dart to update the constraint.

The constraint `^0.11.2+8` on process_run does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions process_run to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
55
pub points
21%
popularity

database module origami core framework

Documentation

API reference

License

MIT (LICENSE)

Dependencies

mongo_dart, origamicore, process_run

More

Packages that depend on origami_database