openxr 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

OpenXR for Dart #

Project license Pub package Dartdoc reference Travis CI build status

OpenXR.dart implements Dart bindings for OpenXR 1.0, the open standard and cross-platform API for virtual reality (VR) and augmented reality (AR) hardware.

Installation #

dependencies:
  openxr: ^0.0.4

Prerequisites #

Examples #

Importing the library #

import 'package:openxr/openxr.dart' as xr;

Development #

We recommend Debian 11 (aka Bullseye) as a development environment. If you're on a Mac, you can run Debian in a virtual machine using VMware Fusion or VirtualBox.

Install the Debian packages for the OpenXR SDK's loader as follows:

$ apt install libopenxr-loader1

That's the only required package, but find related packages of interest using:

$ apt search openxr

In addition, you will need an OpenXR runtime for your hardware. In the absence of suitable vendor-supplied runtimes, have a look at the open-source Monado project which supports many common devices.

See Also #

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

example/example.dart

/* This is free and unencumbered software released into the public domain. */

import 'package:openxr/openxr.dart' as xr;

void main() {
  // TODO
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  openxr: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:openxr/openxr.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:ffi via the import chain package:openxr/openxr.dartpackage:openxr/src/abi.dartdart:ffi

Package not compatible with runtime web

Because of the import of dart:ffi via the import chain package:openxr/openxr.dartpackage:openxr/src/abi.dartdart:ffi

Health suggestions

Fix lib/src/abi.dart. (-0.50 points)

Analysis of lib/src/abi.dart reported 1 hint:

line 3 col 8: Unused import: 'dart:ffi'.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.1 <3.0.0
meta ^1.1.8 1.1.8
Dev dependencies
test any