openpay_flutter 0.0.18

openpay_flutter #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

[0.0.2] - TODO: Add release date.

add methods for card operations.

[0.0.3] - TODO: Add release date.

change exceptions to json format

[0.0.4] - Adnroid antifraud

integrate antifraud detection for android

[0.0.5] - Adnroid antifraud

rename class

[0.0.6] - Adnroid antifraud

remove card metho

[0.0.7] - Adnroid antifraud

remove card method fix

[0.0.8] - fix delete return

204 = ok

[0.0.9] - add pay transaction

submit charge

[0.0.10] - fix transaction json

fix transaction json

[0.0.11] - IOs Support

IOs Support

[0.0.12] - andorid truncate extre chars

truncate session id for android

[0.0.12] - add merchand and api key as parameters

add merchand and api key as parameters

[0.0.14] - add merchand and api key as parameters

add merchand and api key as parameters

[0.0.15] - update dependencides

update dependencides

[0.0.16] - change charge return

change charge return

[0.0.17] - use devisession id for test hardcoded

use devisession id for test hardcoded

[0.0.18] - recompile

recompile

example/README.md

openpay_flutter_example #

Demonstrates how to use the openpay_flutter plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  openpay_flutter: ^0.0.18

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:openpay_flutter/openpay_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
38
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Sep 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.70 points)

484 out of 489 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/model/card.dart. (-12.66 points)

Analysis of lib/model/card.dart reported 27 hints, including:

line 11 col 13: Name non-constant identifiers using lowerCamelCase.

line 12 col 12: Name non-constant identifiers using lowerCamelCase.

line 13 col 12: Name non-constant identifiers using lowerCamelCase.

line 14 col 12: Name non-constant identifiers using lowerCamelCase.

line 15 col 12: Name non-constant identifiers using lowerCamelCase.

Fix lib/model/payment_method.dart. (-9.54 points)

Analysis of lib/model/payment_method.dart reported 20 hints, including:

line 10 col 12: Name non-constant identifiers using lowerCamelCase.

line 14 col 12: Name non-constant identifiers using lowerCamelCase.

line 15 col 12: Name non-constant identifiers using lowerCamelCase.

line 16 col 12: Name non-constant identifiers using lowerCamelCase.

line 17 col 12: Name non-constant identifiers using lowerCamelCase.

Fix lib/model/transaction.dart. (-9.08 points)

Analysis of lib/model/transaction.dart reported 19 hints, including:

line 15 col 14: Name non-constant identifiers using lowerCamelCase.

line 19 col 12: Name non-constant identifiers using lowerCamelCase.

line 20 col 12: Name non-constant identifiers using lowerCamelCase.

line 22 col 12: Name non-constant identifiers using lowerCamelCase.

line 24 col 12: Name non-constant identifiers using lowerCamelCase.

Fix additional 22 files with analysis or formatting issues. (-61.29 points)

Additional issues in the following files:

  • lib/model/subscription.dart (18 hints)
  • lib/model/open_pay_fees_summary.dart (12 hints)
  • lib/model/plan.dart (12 hints)
  • lib/model/customer.dart (10 hints)
  • lib/services/open_pay_base_service.dart (9 hints)
  • lib/model/bank_account.dart (8 hints)
  • lib/model/payment.dart (8 hints)
  • lib/model/payout_summary.dart (6 hints)
  • lib/model/points_balance.dart (6 hints)
  • lib/utils/openpay_client.dart (6 hints)
  • lib/model/address.dart (4 hints)
  • lib/model/exchange_rate.dart (4 hints)
  • lib/model/merchant.dart (4 hints)
  • lib/services/payments_service.dart (4 hints)
  • lib/model/card_points.dart (3 hints)
  • lib/services/card_service.dart (3 hints)
  • lib/model/affiliation.dart (2 hints)
  • lib/model/store.dart (2 hints)
  • lib/model/web_hook.dart (2 hints)
  • lib/services/customer_service.dart (2 hints)
  • lib/model/deferral_payments.dart (Run flutter format to format lib/model/deferral_payments.dart.)
  • lib/model/open_pay_base_model.dart (Run flutter format to format lib/model/open_pay_base_model.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (dio, json_annotation).

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^2.1.12 2.2.1 3.0.0
flutter 0.0.0
json_annotation ^2.4.0 2.4.0 3.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
meta 1.1.7
path 1.6.4
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner ^1.6.1
flutter_test
json_serializable ^3.0.0