openiothub_gateway_service 0.0.3 copy "openiothub_gateway_service: ^0.0.3" to clipboard
openiothub_gateway_service: ^0.0.3 copied to clipboard

OpenIoTHub gateway service

0
likes
130/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 7 API elements (42.9 %) have documentation comments.

Some symbols that are missing documentation: openiothub_gateway_service, openiothub_gateway_service.run, openiothub_gateway_service_bindings_generated, openiothub_gateway_service_bindings_generated.OpeniothubGatewayServiceBindings.Run.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:openiothub_gateway_service/openiothub_gateway_service.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: Unused import: 'dart:async'.

lib/openiothub_gateway_service.dart:2:8

  ╷
2 │ import 'dart:async';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/openiothub_gateway_service.dart

WARNING: Unused import: 'dart:isolate'.

lib/openiothub_gateway_service.dart:5:8

  ╷
5 │ import 'dart:isolate';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/openiothub_gateway_service.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.