openid_client_implicit_flow 0.2.6

Library for working with OpenID Connect and implementing clients.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 97 out of 170 API elements (57.1 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 82 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/openid_client_implicit_flow.dart:11:19

   ╷
11 │     addSubcommand(new ListIssuersCommand());
   │                   ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/openid_client_implicit_flow.dart

INFO: Unnecessary new keyword.

bin/openid_client_implicit_flow.dart:12:19

   ╷
12 │     addSubcommand(new DiscoverIssuerCommand());
   │                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/openid_client_implicit_flow.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.01.6.01.6.0
flutter_webview_plugin^0.3.10.3.110.3.11
http^0.12.00.12.20.12.2
jose^0.1.20.1.2+10.2.1+1
logging^0.11.3+20.11.40.11.4
pointycastle^1.0.0-rc41.0.21.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
crypto_keys-0.1.30.1.3
fixnum-0.10.110.10.11
flutter-0.0.00.0.0
http_parser-3.1.43.1.4
matcher-0.12.90.12.9
meta-1.1.81.2.3
path-1.7.01.7.0
pedantic-1.9.01.9.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on jose does not support the latest published version `0.2.1+1`

pubspec.yaml:11:9

   ╷
11 │   jose: ^0.1.2
   │         ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

Library for working with OpenID Connect and implementing clients.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

wrighter555@gmail.com

License

BSD (LICENSE)

Dependencies

args, flutter_webview_plugin, http, jose, logging, pointycastle

More

Packages that depend on openid_client_implicit_flow