opencage_geocoder 1.0.1
opencage_geocoder: ^1.0.1 copied to clipboard

Dart native
Flutter Android iOS

Dart client for the OpenCage forward/reverse geocoding API

1
likes
55 / 110
pub points
62 %
popularity

We analyzed this package on Jan 15, 2021, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:20:10

   ╷
20 │ <p>MIT © <a href="http://aloisdeniel.github.io">Aloïs Deniel</a></p>
   │          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 146 API elements (3.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:opencage_geocoder/opencage_geocoder.dart that imports:
  • package:opencage_geocoder/src/geocoder.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

INFO: Don't explicitly initialize variables to null.

lib/src/geocoder.dart:23:7

   ╷
23 │       String countryCode = null,
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/geocoder.dart

INFO: Don't explicitly initialize variables to null.

lib/src/geocoder.dart:24:7

   ╷
24 │       Bounds bounds = null,
   │       ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/geocoder.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
json_annotation^3.0.13.1.13.1.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
55
pub points
62%
popularity

Dart client for the OpenCage forward/reverse geocoding API

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alois.deniel@gmail.com

License

MIT (LICENSE)

Dependencies

json_annotation

More

Packages that depend on opencage_geocoder