openapi_generator_cli 1.0.8

  • Readme
  • Changelog
  • Installing
  • 68

pub package

CLI generator wrapper for dart/flutter implementation of openapi client code generation.

OpenAPI Generator allows generation of API client libraries (SDK generation), server stubs, documentation and configuration automatically given an OpenAPI Spec. Please see OpenAPITools/openapi-generator for more information

license.

Usage #

Run

pub global activate openapi_generator_cli

Then you can run the generator using the command below.

openapi-generator <command>

See OpenAPITools/openapi-generator for more commands

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.8 #

1.0.5 #

  • Updated openapi to 4.3.0

1.0.1 #

  • Updated docs

1.0.0 #

  • Updated readme

0.0.3 #

  • Support for inclusion of JAVA arguments

0.0.1 #

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate openapi_generator_cli

2. Use it

The package has the following executables:


$ openapi-generator
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting openapi_generator_cli... Initialized dartdoc with 37 libraries in 31.8 seconds Validating docs... no issues found Documented 0 public libraries in 5.6 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:218:9)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
Dev dependencies
pedantic ^1.9.0
test ^1.14.3