one_context 1.1.0
one_context: ^1.1.0 copied to clipboard

OneContext provides a simple way to deal with Dialogs, Overlays, Navigations, Theme* and MediaQuery* with no need of BuildContext.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add one_context

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  one_context: ^1.1.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:one_context/one_context.dart';
54
likes
120
pub points
87%
popularity

OneContext provides a simple way to deal with Dialogs, Overlays, Navigations, Theme* and MediaQuery* with no need of BuildContext.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fastencoding@gmail.com

License

BSD (LICENSE)

Dependencies

back_button_interceptor, flutter, shared_preferences

More

Packages that depend on one_context