onboarding_plus 0.1.1 copy "onboarding_plus: ^0.1.1" to clipboard
onboarding_plus: ^0.1.1 copied to clipboard

You can create a simple onboarding using this package. Just give your pre-selected colors.

100/ 140
pub points

We analyzed this package 6 days ago, and awarded it 100 pub points (of a possible 140):

Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 33 API elements (3.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: onboarding_plus, onboarding_plus.OnboardingViewer, onboarding_plus.OnboardingViewer.OnboardingViewer, onboarding_plus.OnboardingViewer.activatedDotColor, onboarding_plus.OnboardingViewer.backgroundColor.

10/10 points: Package has an example

Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web


  • package:onboarding_plus/onboarding_plus.dart that imports:
  • dart:io
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/onboarding_plus.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dots_indicator ^2.1.0 2.1.2 3.0.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.0` on dots_indicator does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions dots_indicator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

pub points


verified publishererayhamurlu.com

You can create a simple onboarding using this package. Just give your pre-selected colors.

Repository (GitHub)
View/report issues


API reference


unknown (LICENSE)


dots_indicator, flutter


Packages that depend on onboarding_plus