observable 0.22.2

Dart native js
Flutter Android iOS web

Support for marking objects as observable

7
likes
80 / 110
pub points
94 %
popularity

We analyzed this package on Oct 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 107 API elements (85.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 82 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/change_notifier.dart:26:26

   ╷
26 │       return (_changes ??= new StreamController<List<C>>.broadcast(
   │ ┌──────────────────────────^
27 │ │       sync: true,
28 │ │       onListen: observed,
29 │ │       onCancel: unobserved,
30 │ │     ))
   │ └─────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/change_notifier.dart

INFO: Unnecessary new keyword.

lib/src/change_notifier.dart:99:11

   ╷
99 │     throw new UnsupportedError('Not supported by ChangeNotifier');
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/change_notifier.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.11.01.14.131.14.13
dart_internal^0.1.10.1.12-nullsafety0.1.12-nullsafety
meta^1.0.41.2.31.2.3
quiver>=0.24.0 <3.0.02.1.32.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.90.12.9
path-1.7.01.7.0
stack_trace-1.9.51.9.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs