objd 0.3.3-beta.3
objd: ^0.3.3-beta.3 copied to clipboard

objd is an Object Oriented framework for Building Minecraft Datapacks with ease

2
likes
70/ 130
pub points
55%
popularity

We analyzed this package on Nov 10, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2143 out of 3766 API elements (56.9 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

SDK issues found:

Package is not compatible with the Dart SDK.

Because it is not compatible with any of the supported runtimes: native-aot, native, js.

Package is not compatible with Dart SDK using runtime native-aot. Because:

  • package:objd/build/io_html.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime native. Because:

  • package:objd/build/io_html.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime js. Because:

  • package:objd/build/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/utils/server_version_check.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.132.0.133.1.6
colorize^2.0.02.0.03.0.0
gson^0.1.30.1.40.1.4
meta^1.1.71.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
path-1.8.01.8.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.13` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^2.0.0` on colorize does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions colorize to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

2
likes
70
pub points
55%
popularity

Publisher

stevertus.com

objd is an Object Oriented framework for Building Minecraft Datapacks with ease

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

BSD-2-Clause (LICENSE)

Dependencies

archive, colorize, gson, meta

More

Packages that depend on objd