nui_config_logic 0.0.3
nui_config_logic: ^0.0.3 copied to clipboard

A new Flutter package for logic rendering and processing based on a json

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package 5 hours ago, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 312 API elements (0.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:nui_config_logic/nui_config_logic.dart that imports:
  • package:nui_config_logic/condition/nui_condition_key_map.dart that imports:
  • package:nui_config_logic/condition/nui_condition_matrix.dart that imports:
  • package:nui_config_logic/condition/nui_condition_value.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/nui_sharedpref_util.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

lib/calculation/nui_eq_brac.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/calculation/nui_eq_decoder.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
nui_core^0.0.1280.0.2400.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
animator-3.1.03.1.0
args-1.6.02.3.0
async-2.8.22.8.2
cached_network_image-3.2.03.2.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
csslib-0.17.10.17.1
device_info-2.0.32.0.3
device_info_platform_interface-2.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_markdown-0.2.00.6.8
flutter_staggered_grid_view-0.3.40.4.1
flutter_svg-0.22.01.0.0
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
html2md-1.2.51.2.5
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
ios_utsname_ext-1.1.02.1.0
js-0.6.30.6.3
line_awesome_flutter-2.0.02.0.0
markdown-2.1.84.0.1
meta-1.7.01.7.0
nui_animation-0.0.20.0.2
octo_image-1.0.11.0.1
path-1.8.01.8.0
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler-8.3.08.3.0
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
pull_to_refresh-2.0.02.0.0
rxdart-0.27.30.27.3
shared_preferences-2.0.92.0.9
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
shimmer-1.1.22.0.0
skeleton_loader-1.0.2+32.0.0+4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
states_rebuilder-4.4.05.0.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-6.0.176.0.17
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
visibility_detector-0.2.20.2.2
win32-2.3.12.3.1
workmanager-0.2.40.4.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.128` on nui_core does not support the stable version `0.1.1`.

Try running dart pub upgrade --major-versions nui_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
50
pub points
0%
popularity

A new Flutter package for logic rendering and processing based on a json

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, nui_core

More

Packages that depend on nui_config_logic